Today I thought it’s time to install digikam and play with it. I was using digikam when I was still on Ubuntu and compared to F-Spot and Shotwell, digikam was way way superior when it comes to tag management.

Of course I immediately ran

sudo aptitude install digikam

and installed diigkam 2.6.0 along with its necessary dependencies.


The Problem

Then I just ran


and I started, asked me some useful questions and then greeted me with:

QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
[0x2f86b90] main services discovery error: no suitable services discovery module
digikam: symbol lookup error: /usr/lib/qt4/plugins/phonon_backend/ undefined symbol: libvlc_audio_filter_list_get

Normally I don’t pay attention to the messages in the terminal after starting a program (Hello, Iceweasel), but digikam was nice enough to crash, so that I would not distract me from the error message. How kind.


The Solution

When looking at the error message, you can see that the file “/usr/lib/qt4/plugins/phonon_backend/” plays some role here. And playing around with aptitude you can find a package named “phonon-backend-vlc”. The package name matches the file having the problem quite nicely. I am convinced now, that the solution is to remove the package (be sure you do not need it):

sudo aptitude remove phonon-backend-vlc

Aptitude might then suggest to remove a bunch of other stuff as well (digikam among them), which I find counter-productive. So I just enter “n” the first few times until I am satisfied with the solution aptitude offers me:

The following actions will resolve these dependencies:

     Install the following packages:                   
1)     phonon-backend-gstreamer [4: (testing)]

That does not sound too bad, so I accept it.

When aptitude is done removing the phonon-backend-vlc package, I try it again:


And now it works.